Problema problema, el Alesis Trigger Io tiene7ms de latencia.

Tema en 'Baterías electrónicas' comenzado por lagoausente, 29 de Diciembre de 2010.

  1. Bueno, antes de que me respondais que el buffer Asio, que el Asio4all, ya os digo que no, en esto no soy novato.
    Me ha parecido lento y me puesto a medir la latencia real de trigger a midi.
    Dos métodos:
    1) mandando el audio del metronomo en estereo, canal L grabado a la tarjeta Scope Pro Pulsar, el otro canal al Alesis Trigger I/O.
    Abriendo dos sintes iguales (trabajan con dsp), uno alimentado por el midi del alesis y el otro por un trigger tambien DSP.
    Comparando los tres audios, el trigger DSP tarda 2ms respecto al audio, y el del Alesis 9ms.

    Método 2:
    Haciendo un cable de la salida midi y grabandolo por la entrada de audio. Sí, son bits pero se puede ver la forma de onda de cuando manda los eventos. El midi llega 7ms más tarde que el audio.

    Esta prueba la había hecho anteriormente con un SPD11 que vendí, y tardaba 1 ms, lo cual es relativamente normal.
    Acto seguido me puse a buscar en google y me encontré varios casos de gente diciendo lo mismo, el Alesis Trigger I/o tiene una latencia el solo de entre 6 y 10ms el solo, mayor que la de tu propia tarjeta de audio. Claro, habra muchos la mar de contentos porque tienen el buffer a 32, y creen que tienen 1ms de latencia y en realidad tienen 10ms, pero bueno..

    El caso es quiero devolver esto a Thomman y comprarme un módulo rápido. Si alguien me puede orientar o tiene algún modulo tipo Roland o DTX-press y quiera testear la latencia real pues se agradeceria, o cualquier otra ayuda para elegir por qué modulo lo cambio.
    Gracias y un saludo.
     
  2. Yo tengo el modulo dtxpress IV,pero aun no lo he probado por midi.
    Tuve problemas hace tiempo con la latencia dichosa por midi al conectar dos sintes para usarlos con VST,s de Cubase y lo solucione usando los ultimos drivers actualizados de la propia tarjeta de sonido,una M-Audio y NO usando los famosos asio4all.
    Jugaba con los valores los drivers de la propia tarjeta y en Cubase apuntando al driver nativo de la M-audio sin usar asio.
    Otro truco era atacar con un teclado por el midi in de la propia M-audio y el otro por otra interfaz midi in de una edirol midi usb.
    Aunque me huele que ese hardware no dara para mucho mas y no tiene actualizacion de firmware en su web.Prueba a ver...
    Saludos.
     
  3. Buscaré en google porque dudo que el firmware le vaya a cambiar ese comportamiento. La putada es que con la tarjeta Scope Pro tengo 3ms de latencia de salida. La latencia del trigger dsp en realidad era 1ms no 2ms, ya que 1ms se lo comía el sinte y el otro ms el trigger. Es lo suyo serían total 4ms. Pero así se convierten en 13ms aprox.
    Puees nada, a seguir rebuscando en google.
    Tambien he pensado en comprarme una tarjeta de sonido con salida ADAt muticanal y usar el trigger en la tarjeta DSP, el probrela aqui es convertir el pedal de hit hat... fff
    He encontraro un hilo donde ponen algunos resultados en ms de algunos modulos:
    http://www.vdrums.com/forum/showthread.php?p=546043#post546043
     
  4. Hola.

    El tema de la latencia es siempre complicado. Empezaré diciendo que 7 ó 9 ms no me parece demasiado ¿has hecho esas pruebas porque has percibido un retardo o simplemente porque no te convence el valor?

    Tengo una interfaz de audio Lexicon Ionix U22, su valor en una configuración junto a un iMac Dual Core 3.06 es de 7ms y no he tenido el más mínimo problema, ni con audio, ni con MIDI.

    Totalmente de acuerdo en intentar actualizar los drivers del fabricante antes de utilizar unos genéricos. ¿Podrías detallar algo más cómo has hecho las pruebas? Porque creo que hay factores indirectos que están afectando. ¿Qué cables utilizas? ¿MIDI, USB...? ¿Longitud?

    Con plugins es más habitual tener problemas de latencia.
     
  5. hola!!!!!yo tuve el alesis io por mas de 3 años y la verdad lo he conectado a todo tipo de pcs
    pues bien una latencia de transmision de datos no existe en el aparato sino en la reproduccion de la tarjeta de audio
    lo mas conveniente es probar conectandolo en un sinte directamente y asi probar el retardo
    yo nunca tuve problemas de latencia pues usaba una interfaz Maudio delta 10 10 en mi pc de escritorio y una usb en mi laptop

    aunque hace poco lei que alguien conecto un alesis trigger io en un roland td9 para ampliarlo y generaba latencia
    eso esta muy raro
    :(
     
  6. No es nada raro, el Alesis tiene 7ms de retardo entre que recibe la señal del piezo y que envía los datos midi. Es tan sencillo de comprobar como hacer un cable desde el midi a tu entrada analógica de tu tarjeta, sí ya se que son datos digitales pero puedes ver cuando envia los bits en la forma de onda. Grabas en otro canal la propia salida del pad con un cable Y y puedes ver el retardo real.
    Hay más maneras de medirlo, como tu dices con sintes, tambien lo he probado y coincide. Es más, es lógico que tenga los 7ms de retardo,¿por qué? pues porque cuanto menos retardo menos tiempo tiene el cacharro para analizar la señal que le envía el pad y determinar su amplitud. Esto lo aprendí mirando la página del megadrum: http://www.megadrum.info/content/miscellaneous-settings
    Ahí lo explica, ya he vendido el Alesis y me he fabricado el megadrum, bastante facil por cierto ya que Dmitri te envía el kit todo soldado, solo hay que meterlo en una caja y soldar los jacks de entrada.
    Sale más caro que el Alesis pero puedes configurar la latencia de cada entrada. Como tiene 56, pues me he permitido el lujo de duplicar cada pad, con lo cual saco por el canal 10 midi con 2ms de retardo (para monitorizar), y por el canal midi 1 (para grabar) con 8ms de retardo. Estoy hablando de retardo trigger-midi solamente.
    La ventaja que tiene esto es que el que va grabado con 8ms de latencia tiene mejor precision de los niveles con que golpeas los pads, y con 2ms pierde precision de niveles (casi ni se nota), y menos retardo.
    La tarjeta que tengo va con unos 1.5ms, 3ms reales porque llevan un buffer de seguridad, calculo que ahora son unos 6ms en total, cuanto antes era unos 14ms.
     
Cargando...

Comparte esta página